Excel Makro (Vba) ile Yazdırma İşlemleri PrintOut Kullanımı

Bu yazımızda Excel ile hazırlamış olduğunuz Çalışma Kitabı, Sayfalar, Seçilen Hücreler veya grafikleri Vba kodları ile yazdırma işlemi nasıl yapılır örnekleri ile açıklamaya çalışacağım.
Yazdırma işlemi için kullanacağımız fonksiyon .PrintOut şimdi örneklerle Excelde Vba kodları ile yazdırma işlemi nasıl yapılır inceleyelim
Vba kodu ile Çalışma kitabını yazdırma

Function Yazdir()
      ActiveWorkbook.PrintOut
End Function

Vba kodu ile Aktif çalışma sayfasını yazdırma

Function Yazdir()
       ActiveSheet.PrintOut
End Function

Vba kodu ile tüm çalışma sayfasını yazdırma

Function Yazdir()
       WorkSheets.PrintOut
End Function

Vba kodu ile Seçilen çalışma sayfasını yazdırma

Function Yazdir()
       Sheets("Sayfa1").PrintOut
End Function

Vba kodu ile Birden fazla çalışma sayfasını yazdırma

Function Yazdir()
       Sheets(Array("Sayfa1","Sayfa3","Sayfa4")).PrintOut
End Function

Vba kodu ile seçilen alanı yazdırma

Function Yazdir()
       Selection.PrintOut
End Function

Vba kodu ile seçilen hücre aralığını yazdırma

Function Yazdir()
      Range("A1:D5").PrintOut
End Function

Vba kodu ile excel grafiğini yazdırma

Function Yazdir()
     Sheets("Sayfa1").ChartObjects("Grafik_ismi").Chart.PrintOut
End Function

Vba kodu ile Sayfadaki tüm grafikleri yazdırma

Function Yazdir()
    Dim Grafikler As Object
Set Grafikler = Sheets("Sayfa1").ChartObjects
For Each Grafik In Grafikler
    Grafik.Chart.PrintOut
Next
End Function

Vba kodu ile Çalışma Kitabındaki tüm grafikleri yazdırma

Function Yazdir()
    Dim Grafikler As Object
	For Each Sayfa In Sheets
		Set Grafikler = Sayfa.ChartObjects
		For Each Grafik In Grafikler
			Grafik.Chart.PrintOut
		Next
		Set Grafikler = Nothing
	Next
End Function

Vba kodu ile Çalışma Sayfasındaki Belli Sayfaların Yazdırılması

Function Yazdir()
'Sayfa 1 den 3 e kadar olanlar yazılacak diğerleri yazdırılmayacak
    Worksheets("Sayfa1").PrintOut From:=1, To:=3
End Function

Makro (Vba) ile Excel Çalışma Sayfasını Pdf Olarak Kaydetme

Bu dersimizde Makro (Vba) ile Excel Çalışma Sayfasını Pdf Olarak Kaydetme işlemi nasıl yapılır anlatmaya çalışacağım. Bazı durumlarda oluşturduğunuz excel çalışma kitabının tümünü, çalıştığınız bir sayfayı yada seçmiş olduğunuz hücre aralıklarını pdf formatında kaydetmek isteyebilirsiniz bu işlem için kullanabileceğiniz kodlar..:

1-Aktif Olan Çalışma Sayfasını Pdf Olarak Kaydetme
C:\Users\Vento\File_Name.pdf bizim dosyamızı kaydedeceğimiz yol bunu kendinize göre düzenleyebilirsiniz.

With ActiveSheet
    .ExportAsFixedFormat _
    Type:=xlTypePDF, _
    Filename:="C:\Users\Vento\File_Name.pdf", _
    Quality:=xlQualityStandard, _
    IncludeDocProperties:=True, _
    IgnorePrintAreas:=False, _
    OpenAfterPublish:=False
End With

2-Seçeceğiniz Excel Çalışma Sayfasını Pdf Olarak Kaydetme
Sheets(“Sayfa2”) kısmına pdf olarak kaydedilecek excel sayfasının ismini yazıyoruz ve yine C:\Users\Vento\File_Name.pdf bizim dosyamızı kaydedeceğimiz yol bunu kendinize göre düzenleyebilirsiniz.

With Sheets("Sayfa2")
    .ExportAsFixedFormat _
    Type:=xlTypePDF, _
    Filename:="C:\Users\Vento\File_Name11.pdf", _
    Quality:=xlQualityStandard, _
    IncludeDocProperties:=True, _
    IgnorePrintAreas:=False, _
    OpenAfterPublish:=False
End With

3-Seçilen Hücre Aralığını Pdf Olarak Kaydetme
Sheets(“Sayfa1”).Range(“A1:B22”) bölümünde sayfa ismi ve pdf olarak kaydedilecek hücre aralığını seçiyoruz..

With Sheets("Sayfa1").Range("A1:B22")
    .ExportAsFixedFormat _
    Type:=xlTypePDF, _
    Filename:="C:\Users\Vento\File_Name22.pdf", _
    Quality:=xlQualityStandard, _
    IncludeDocProperties:=True, _
    IgnorePrintAreas:=False, _
    OpenAfterPublish:=False '
End With

Ofis Belgelerine (Word-Excel-PowerPoint) Font Ekleme-Font Gömme

Word-Excel-PowerPoint ile hazırlamış olduğunuz herhangi bir ödev veya sunum doyasını bir arkadaşınıza veya hocanıza 🙂 mail attınız ancak kullandığınız fontlar diğer bilgisayarda yüklü değilse görünüm bozulacak ve varsayılan yazı tipi ile görüntülenecektir. Ancak bu sorunu Word-Excel-PowerPoint belgesine font ekleyerek ortadan kaldırabilirsiniz..

Bu seçenek ile görüntülemede kullanılacak font hazırlanan ofis belgesine eklenir; her ne kadar bu işlem sonucunda dosya boyutu bir miktar artsa da herkes aynı biçimde dosyayı kullanacaktır. Tabi bu işlem için fontun ekleme işlemine izin vermesi yani eklenebilir bir font olması gerekir.
İlk olarak Dosyan Menüsünü seçiyoruz

Daha sonra Seçenekler

Karşımıza gelen pencereden Kaydet menüsünü tıklıyoruz.

Bu Belgeyi paylaşırken aslını koru bölümünden “Yazı tiplerini dosyaya ekle” seçeneğini seçiyoruz.

ve son olarak dosya boyutunun çok büyümesini engellemek için “Yalnızca dosyada kullanılan karakterleri ekle seçeneğini işaretlemeniz yeterli 🙂

Artık bütün ofis belgeleriniz tüm bilgisayarlarda aynı şekilde açılacak….

Excel’de Durum Çubuğunda Özet verileri Görüntüleme


Excelde seçili hücrelerdeki bilgilerin özet verilerini yani seçili hücrelerin ortalaması, veri içeren hücre sayısı, toplamı, en büyük ve en küçük değer gibi bilgileri durum çubuğunda görüntülemek için yapmamız gereken durum çubuğu üzerinde sağ tıklayıp açılan seçeneklerden durum çubuğunda görüntülemek istediklerimizi seçmek hepsi bu kadar ..:

Excel’de Ayırıcı Değişikliği Virgül Yerine Nokta, Nokta Yerine Virgül

Binlik ve Ondalık basamakları ayırmak nokta yerine virgül, virgül yerine nokta koymak için Denetim masasından Saat,Dil ve Bölge ayarları altından yapılmaktadır ama bu işlemi excel’de uygulamak istiyorsanız
Dosya->Seçenekler-> Gelişmiş->Düzenleme Seçenekleri->Sistem ayırıcılarını kullan (onay kutusunu iptal ederek) Ondalık ve Binlik Ayırıcı değişikliğini Yapabilirsiniz..

Excel Formül Uygulaması – Öğrenci Not Tablosu


Excel uygulamamızda öğrencilerin vize ve final sınavlarına göre not ortalamasını hesaplayan buna göre başarı notu, ortalaması, başarılı başarısız durumu, en yüksek en düşük not alan öğrenciler, not ortalamaları hesaplanmaktadır. buna göre kullanılacak formüller.
Vize Not Hesabı

=E2*40%

Final Not Hesabı

=G2*60%

Not Toplamı

=TOPLA(F2;H2)

Harf Notu

=EĞER(I2>=85;"AA";EĞER(I2>=70;"BB";EĞER(I2>=60;"CC";EĞER(I2>=40;"DD";"FF"))))

Başarı Notu

=EĞER(I2<40;"BAŞARISIZ";EĞER(I2<60;"ORTALAMA";"BAŞARILI"))

En Yüksek Not

=MAK(I2:I16)

En düşük Not

=MİN(I2:I16)

Sınav Notlarının Ortalaması

=YUVARLA(ORTALAMA(I2:I16);0)

Dersten Geçen öğrenci sayısı

=EĞERSAY(I2:I16;">=40")

Excel 2010 Uygulama Örnekleri

5539012001a2_cover
Microsoft Excel 2010 ile yapılmış uygulamalar ve örnekler, aşağıdaki bağlantıdan Excel 2010 uygulama örneklerini indirebilirsiniz klasör içeriğinde Genel Hesaplama,Eğer,Eğersay,Sırlama, Koşullu Biçimlendirme, Alt Toplam Hesaplama, Metin İşlemleri, Filtreleme işlemleri, Matematiksel fonksiyonlar ve grafikler, Metinsel fonksiyonlarla alakalı uygulamalar mevcut..
[Yükleme bulunamadı.]